Fixing 10.4.1's issues with GPGMail

10.4.1 semi-breaks the GPGMail plugin. To fix it,

  1. run Mail, let it disable the plugin
  2. quit Mail
  3. rename the Bundles-disabled back to Bundles
  4. Open Terminal
  5. defaults write com.apple.mail EnableBundles 1
  6. restart Mail

The plugin should work again. Note that we're using 1 and not YES (like the plugin docs for 10.4.0 said).

According to the mailing list, if you follow the previous directions from the dmg, and set BundleCompatibilityVersion to 1, that triggers the new Mail in 10.4.1 to complain and disable the bundle.

No comments:

Creative Commons License

This work is licensed under a Creative Commons License.
Copyright 2007-2010, Joseph P. Block, Some Rights Reserved.

Creative Commons Logo